In the Forums

Register

Today's Posts

Search

Get the Weekly
Inkling
newsletter





Previous Issues

Get Social

Splitcoaststampers on InstagramLike Splitcoaststampers on FacebookFollow Splitcoaststampers on TwitterPit Splitcoaststampers on Pinterest

Sponsored Ads


 
Splitcoaststampers.com - the world's #1 papercrafting community
You're currently viewing Splitcoaststampers as a GUEST. We pride ourselves on being great hosts, but guests have limited access to some of our incredible artwork, our lively forums and other super cool features of the site! You can join our incredible papercrafting community at NO COST. So what are you waiting for?

Join the party at Splitcoaststampers today!

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-14-2011, 07:47 PM   #1
Compulsive Stamper
 
Join Date: Dec 2007
Posts: 40
Default SU unmounted stamps problem

I seem to have a problem with my unmounted SU stamps clinging to the block.
Does anyone else have this problem or am I doing something wrong.
Thanks, Jo Ann
iupindiana is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-14-2011, 10:56 PM   #2
Splitcoast Challenge Hostess
 
kstamper's Avatar
 
Join Date: Nov 2004
Location: Trying to find myself
Posts: 4,920
Default

After I unmount my stamps from the block, I peel the sticker off the block and stick it to the foam, then trim the excess from the edges. Then I apply a small amount of Aleene's Tack it Over and Over to the center of the sticker. Once the Aleene's dries (overnight) it will stick to an acrylic block.

If you have any questions, you can PM me.
__________________
Former CAS Design Team Member
My blog - Syzygy of Me
kstamper is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 03:43 AM   #3
Hardware Hotshot
 
Allistamps123's Avatar
 
Join Date: Mar 2008
Location: along the bluffs of the Upper Mississippi River
Posts: 4,129
Default

There's been LOTS of discussion on this topic. I wish SU would come to the rescue of their non-clingy clings! I love SU but the?????? Anyway, I've read where many suggest to leave off the sticker. That's what I do and I don't have a problem with the foam sticking to the block. Others have said clean it off, press hard, etc.
__________________
All I want is the chance to prove money won't make me happy!
Allistamps123 is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 05:58 AM   #4
Splitcoast Dirty Dozen Alumni
Creative Crew SU Design Team Alumni
 
Minders's Avatar
 
Join Date: Aug 2008
Location: Chicagoland
Posts: 15,349
Default

Yes, there are a lot of threads about this topic. The stickers are the problem and they seem to get dirty/not stick well. You can try cleaning the stickers and making sure your blocks are clean and then huffing on the block. I huff on the block and then put the stamp down on the table, rubber side down, and then press the block on really hard for a good 10 seconds. I still don't think it works well. I have some that I have put a bit of tombow glue (in the green and white bottle) and let it dry. Then it will stick better. But it stinks we need to do that.

Alli is right, they work fantastically without the sticker!!!! I have started to not put the sticker on in my last few orders and it has made all the difference! I hope SU works out a solution to this. Good luck.
__________________
My gallery

Check out my blog


Proud SCS Fan Club Member
Minders is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 06:09 AM   #5
Kar
Gabfest Goddess
 
Join Date: Jul 2003
Location: Curtiss, Wisconsin
Posts: 7,255
Default

I have been having that problem too.... There has to be a fix coming soon I hope as I love the unmounted stamps!
__________________
my blog!
my stampin up website
SCS member #735
Kar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 11:10 AM   #6
Compulsive Stamper
 
Join Date: Dec 2007
Posts: 40
Default

I am relieved to know that I am not the only one having a problem. Thanks for the help.
iupindiana is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 11:39 AM   #7
Kookie Creator
 
Join Date: Feb 2008
Location: Salt Lake City UT
Posts: 418
Default

Alli is right, they work fantastically without the sticker!!!! I have started to not put the sticker on in my last few orders and it has made all the difference! I hope SU works out a solution to this. Good luck.[/QUOTE]

That is a good idea. I unmounted all of my stamps and most of them do not have a sticker of any kind on. Next SU set I get, I will leave the sticker off and see how it works. Since I cut out my stamped image and layer it, precision at that point isn't too important. I have the same problem with my Hero Arts rubber cling stamps. Must be the sticker that comes on those. Both companies stick on my acrylic block, but they don't want to stick to the SU case or the mounting pages I stick my HA stamps to. Thanks
Cindy Littler is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 11:58 AM   #8
Crimping Master
 
heatherla's Avatar
 
Join Date: Mar 2010
Location: Quesnel, British Columbia
Posts: 1,166
Default

The clear stamps from SU do have issues with not sticking. So, instead of using Alene's Tack-it-Over and Over on them, I find the clear stamps get too overly sticky with that.

So, this is what I do and it works like a charm. I take my clear block, not the stamp but the block, and I run a little bit of snail adhesive over the block. Then I tap my finger on it a few times, to lightened up the stickiness of it. I then put my stamp on the block. The stamp stays super in place and it doesn't move and removing the stamp from the block is super easy.

~~
heatherla is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 12:12 PM   #9
Pearl-ExPert
 
ljwil's Avatar
 
Join Date: Dec 2004
Location: Calgary, AB Canada
Posts: 2,796
Default

Does this mean that I'm the only one that licks the back of the stamp then?
__________________
Lesley

My pitifully neglected gallery

StampingReckLesley (my pitifully neglected blog)
ljwil is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 12:30 PM   #10
Splitcoast Dirty Dozen Alumni
Creative Crew SU Design Team Alumni
 
Minders's Avatar
 
Join Date: Aug 2008
Location: Chicagoland
Posts: 15,349
Default

Quote:
Originally Posted by ljwil View Post
Does this mean that I'm the only one that licks the back of the stamp then?
LOL! Probably not
__________________
My gallery

Check out my blog


Proud SCS Fan Club Member
Minders is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-15-2011, 12:53 PM   #11
Matboard Maniac
 
Join Date: Mar 2007
Location: NE Louisiana
Posts: 202
Default

subbing...



AlliStamps - I love your tagline!
GeryB is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-17-2011, 03:23 AM   #12
Rubber Obsessor
 
Join Date: Sep 2006
Posts: 142
Default

I am so glad to read this thread! Yes, I've had trouble with mine too. In fact I'm thinking of returning to the wooden stamps. I already had acrylic blocks before SU came out with their clear mount so of course my SU demo (who doesn't read Splitcoast) refuses to acknowledge any problem what so ever and it's because I'm not using SU's blocks! I've tried them on hers and it's not made any difference. Just like the problem with my "Little Leaves" die is because I use a Cuttlebug and not a Big Shot! - but that's a storey for another thread. From now I'll will speak up sooner and louder can keep it up! Thanks for the back up everyone!
MaggyMay is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 03-17-2011, 06:04 AM   #13
Splitcoast Dirty Dozen Alumni
Creative Crew SU Design Team Alumni
 
Minders's Avatar
 
Join Date: Aug 2008
Location: Chicagoland
Posts: 15,349
Default

Quote:
Originally Posted by MaggyMay View Post
I am so glad to read this thread! Yes, I've had trouble with mine too. In fact I'm thinking of returning to the wooden stamps. I already had acrylic blocks before SU came out with their clear mount so of course my SU demo (who doesn't read Splitcoast) refuses to acknowledge any problem what so ever and it's because I'm not using SU's blocks! I've tried them on hers and it's not made any difference. Just like the problem with my "Little Leaves" die is because I use a Cuttlebug and not a Big Shot! - but that's a storey for another thread. From now I'll will speak up sooner and louder can keep it up! Thanks for the back up everyone!
I'm sorry you are having trouble with your stamps and with your demo! She should at least offer you some of the suggestions mentioned here. There isn't a lot she can do about the stamps besides that as it's not a "defect" with the stamps per say and they all do it at some point. Like I said, for me, the solution has been to stop using the labels and they stick just fine and I stamp with them just fine (which I was worried about). SU is aware of the issue and I hope that they come up with a better label or find a way to print right on the cling. I do have to give a shout out to the SU blocks! I love them...aside from being great blocks they are so pretty, lol!
__________________
My gallery

Check out my blog


Proud SCS Fan Club Member
Minders is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Reply





Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off