In the Forums

Register

Today's Posts

Search

Get the Weekly
Inkling
newsletter





Previous Issues

Splitcoaststampers's privacy policy

Get Social

Splitcoaststampers on InstagramLike Splitcoaststampers on FacebookFollow Splitcoaststampers on TwitterPit Splitcoaststampers on Pinterest

Sponsored Ads


 
Splitcoaststampers.com - the world's #1 papercrafting community
You're currently viewing Splitcoaststampers as a GUEST. We pride ourselves on being great hosts, but guests have limited access to some of our incredible artwork, our lively forums and other super cool features of the site! You can join our incredible papercrafting community at NO COST. So what are you waiting for?

Join the party at Splitcoaststampers today!

Reply
 
Thread Tools Search this Thread
Old 08-10-2004, 05:41 PM   #1
Stazon Splitcoast
 
row4d's Avatar
 
Join Date: Jun 2004
Posts: 14,640
Default I just can't win!

A few weeks ago I had to get new rubber pieces for my Bold Alphabet because the rubber was detaching from the foam and I hadn't even used the set yet. Now I've pulled out my Seaside Sketches set because I wanted to use one of the sayings with the mother and baby stamp from Sketches. I went to trim the saying, because I hadn't assembled that stamp yet, and when I peeled off the paper it took the adhesive with it! It's not sticky at all! I started to wonder about the other stamps, and the ones I've assembled are coming off of the wood and leaving the adhesive behind! I haven't used any of them yet either!

This is so frustrating. I know it's not the humid Savannah weather, because my other stamps are fine. I don't really feel like dealing with the whole return process again, especially since I'm not sure whether Seaside Sketches is a current set -- I haven't gotten my new catty yet. I don't have any Crystal Effects, and I don't want to use super glue because it dries rock hard. I don't really trust rubber cement to hold in this climate, because people have trouble with things falling off the finish sample boards all the time whenever they use it!
row4d is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 05:47 PM   #2
Glitter Guru
 
thecardpixie's Avatar
 
Join Date: Apr 2004
Location: Boise, ID
Posts: 5,887
Default

Sorry to hear that you're having so much trouble.

I don't know about adhesives, but I do know that Seaside Sketches is a current set.

HTH

-Christina
thecardpixie is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 06:47 PM   #3
Glitter Queen
 
cdellinger10's Avatar
 
Join Date: May 2003
Location: Acworth, GA
Posts: 16
Default

I have found that a few of my alphabet stamps have come loose and I was thinking it might have been from traveling with them in the car. Now, that sounds funny at first but I did have them in the car for several hours and I might not have unpacked the car as soon as I got home. Although I am not in the Savannah heat and humidity I am in the Atlanta weather and I do think that it affects the stamps.

I'm sure you have already thought about this but were these sets located with your other ones? Were they sitting in sunlight or anything else that might have caused the problem? I would just hate for you to keep going through this.

Good luck!
Cassy
cdellinger10 is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 07:05 PM   #4
Stazon Splitcoast
 
row4d's Avatar
 
Join Date: Jun 2004
Posts: 14,640
Default

I ordered both the Bold and Brushstroke Alphabets at the same time, during the deal that SU! had going where you could get a free numbers set. I haven't had any problems with the Brushstroke set.

I heard something back when Seaside Sketches was a mini catalog set (which was when I ordered it) about a whole lot of people getting sets with bad adhesive. Now that I think about it, I remember when I was assembling two of the larger image stamps that the adhesive started to peel off with the paper backing, but I was able to carefully remove the paper in a way that pretty much kept the adhesive intact.
row4d is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 07:20 PM   #5
Gabfest Goddess
 
Inkalicious's Avatar
 
Join Date: Jun 2004
Location: Mission Viejo, CALIF
Posts: 7,659
Default

Did you say you dont have a catalog yet??? OMG thats awful! Where is it?
Tandra
__________________
blog
My SU! Website
SCS Gallery

SA Sistah -Original Swappers Anonymous!
Inkalicious is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 07:36 PM   #6
Polyshrink Goddess
 
lburanas's Avatar
 
Join Date: May 2004
Location: irvine ca
Posts: 556
Default

i had a sellabration set that the adhesive came off w/ the paper, and they replaced it for me. maybe you can call and explain that you never mounted it til now, so that's why it's been so long.
lburanas is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2004, 08:18 PM   #7
Stazon Splitcoast
 
heresrita's Avatar
 
Join Date: Jun 2004
Location: Take off, eh? - to the great white north
Posts: 16,809
Default

Dito Iburanas.

Plus DON'T finish mounting any more stamps. Call SU! and follow their instructions to the letter.
__________________
~rita~
heresrita is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 04:28 PM   #8
Stazon Splitcoast
 
row4d's Avatar
 
Join Date: Jun 2004
Posts: 14,640
Default

I asked my demo what to do when I was home a couple of weeks ago and went to a stamping party at the office, and she suggested I try rubber cement this time to re-adhere the foam to the wood, applying it to both surfaces. I hadn't brought any rubber cement home with me, and didn't have any there (or so I thought -- found a jar as I was getting ready to come back to Savannah). I'm crossing my fingers that this will work, because I have a bunch of ideas for this set now!
row4d is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 04:59 PM   #9
Polyshrink Goddess
 
northernstamper's Avatar
 
Join Date: Feb 2004
Location: BC Canada
Posts: 733
Default

When ever I have the rubber come off the foam, and it does especialy on the small stamps.. I use chrystal effects to fix them. It has worked for me.
northernstamper is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 05:35 PM   #10
Insane Embellisher
 
scrapyme's Avatar
 
Join Date: Jun 2004
Location: Hinesville, Georgia
Posts: 947
Default

If you need a new catty let me know, I am an email away, I have plenty... I too live in the Savannah area and by accident left my stamps set in the car a little too long but they haven't give me any trouble,now the brushstroke alphabet is always coming off the foam,they were not the ones left in the car, I thought that it was me rubbing them too hard on the scrub pad I haven't use them in a while so I have to try them again and see how they will do now.If I keep having trouble I guess the crystal effect sounds like the safer way to reconstruct the stamps
__________________
https://www.splitcoaststampers.com/go/scrapyme

I love to stamp, what a stress reliever!
scrapyme is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 06:03 PM   #11
Kar
Gabfest Goddess
 
Kar's Avatar
 
Join Date: Jul 2003
Location: Curtiss, Wisconsin
Posts: 7,255
Default

I have the scritchy scratch alphabet (retired now I know) and the rubber is constantly sliding off the foam. I am glad to hear I am not the only one, that this has happened to. I just haven't fixed it yet, because it just started doing this.
__________________
my blog!
my stampin up website
SCS member #735
Kar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 06:11 PM   #12
Stazon Splitcoast
 
STAMPINSTEL's Avatar
 
Join Date: Apr 2004
Location: Portland , Oregon
Posts: 20,669
Send a message via Skype™ to STAMPINSTEL
Default

This happened to a set I got several months ago,I don't recall off hand which one it was. I thought it was just mine,But it sounds like I was'nt the only one. I think I had a sheet of double sided adhesive that I used to fix it. You can get it at most craft stores,and it works great. You could try that if you don't want to send it back to the company.
__________________
LASTEL #3810
MY BLOG
My Gallery
STAMPINSTEL is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 06:25 PM   #13
Pearl-ExPert
 
mycattracks's Avatar
 
Join Date: Jan 2004
Location: waiting for the pretty flowers to bloom
Posts: 2,189
Default

what about terrificly tacky tape?
mycattracks is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 06:47 PM   #14
Polyshrink Goddess
 
kandcats's Avatar
 
Join Date: Mar 2004
Location: Hudson, NH
Posts: 722
Default

the rubber cement does work! I have done it - no problems. I have also used that 2 way glue successfully to fix this problem. Good luck!
kandcats is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 07:12 PM   #15
Dirty Dozen Alumni
 
lzappa's Avatar
 
Join Date: Jul 2004
Location: St Paul, Minnesota
Posts: 2,111
Default

Hi! I'm a demonstrator in MN and I had a similar problem with getting bad adhesive on some Sell-A-Bration sets. SU just sent me new rubber to apply to the blocks that we already had; maybe your demo can call and get them to do that for you, so you can start with new rubber with good adhesive. That way you won't have to return the whole set/blocks & all.
lzappa is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 07:44 PM   #16
Stazon Splitcoast
 
row4d's Avatar
 
Join Date: Jun 2004
Posts: 14,640
Default

I think maybe I'll try the rubber cement repair with one of the stamps, and if that doesn't work then I'll get my demo to exchange the rubber for me. She said that in 8 years with SU! she'd never had to deal with this problem -- am I jinxed or something?
row4d is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-16-2004, 07:53 PM   #17
Hardware Hotshot
 
glenda s's Avatar
 
Join Date: May 2004
Location: Kapolei, Hawaii
Posts: 4,529
Default

OK, I think I win for the most humid climate. Rubber cement does NOT work. Crystal effects works perfectly.

Aloha,
Glenda
glenda s is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-17-2004, 02:53 AM   #18
Crimping Master
 
barbaranne_stamps's Avatar
 
Join Date: Sep 2004
Posts: 1,163
Default

It depends when you purchased the stamp set. SU will not replace them if they are more than 90 days old. I had a similar problem with a customer. I was the one who tried to mount the stamps for her. I called SU to get the set replaced and they said 'NO' because it was over 90 days old. They told me to use rubber cement.

I didn't have to do that for this set (I just left it sitting in my house for a month, then it was fine, so I don't know how she had them stored.). Once I purchased unmounted stamps and the directions said to mount them to foamcore using rubber cement. Well, I tried that and it just made everything curl and was so frustrating. I finally ran the stamps through the Xyron and they are still stuck! Worked great!
barbaranne_stamps is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 09-17-2004, 05:36 AM   #19
luvstochatchatCHAT
 
luvtostampstampstamp's Avatar
 
Join Date: Jul 2004
Location: Land of blissful cHaOs
Posts: 34,982
Default

I would definately contact SU. I don't think they would want their customers being unhappy with their stamp sets. I am not a demo but a loyal customer who has returned a few things and been very happy with the service through my demo. If your demo is not interseted in assisting you, maybe you can contact SU directly. I had the SAB Smorgasborders with adhesive problems. Got a new set through returning my other one. You miss your stamp set for a little but it's worth it to get a new one that won't frustrate you!
__________________
OLW for 2020: TRANSFORM
Today is the Day!
luvtostampstampstamp is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Reply





Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off