In the Forums

Register

Today's Posts

Search


Get the Weekly
Inkling
newsletter





Previous Issues

Get Social

Like Splitcoaststampers on Facebook Follow Splitcoaststampers on Twitter Watch Splitcoaststampers Videos on YouTube

Sponsored Ads


 
Splitcoaststampers.com - the world's #1 papercrafting community
You're currently viewing Splitcoaststampers as a GUEST. We pride ourselves on being great hosts, but guests have limited access to some of our incredible artwork, our lively forums and other super cool features of the site! You can join our incredible papercrafting community at NO COST. So what are you waiting for?

Join the party at Splitcoaststampers today!

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 08-09-2009, 06:41 PM   #1
Insane Embellisher
 
Join Date: Nov 2005
Location: Texas
Posts: 3,197
Default New Cricut not working--need help!!

I have a new Cricut Personal Cutter, one of the originals that uses 6 x 12 paper. This is the first time using it. The power adaptor is on and the power light on the machine glows, but the LCD screen remains dark and the machine does nothing. I found steps to "unfreeze" a machine on the Cricut website, but it didn't work. I am so disappointed! It was a gift from my college son and I don't think he has the receipt. Any ideas? Thank you. Did I mention my disappointment?
__________________
Martha

My Gallery
Marthar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 06:45 PM   #2
Glitter Guru
 
Join Date: Sep 2007
Location: Dallas
Posts: 5,509
Default

Do you have the cartridge in the correct way?
53queenbee is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 06:48 PM   #3
Insane Embellisher
 
Join Date: Nov 2005
Location: Texas
Posts: 3,197
Default

Yes, and actually the Cricut website says it can go in either way.
__________________
Martha

My Gallery
Marthar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 06:56 PM   #4
Glitter Guru
 
Join Date: Sep 2007
Location: Dallas
Posts: 5,509
Default

Mine did that once but I unplugged everything and let it rest for about a minute and replugged it again. I have the original, first day they came out model and I cannot put the cartridge in but one way to make it work.

I am no help huh? But, I can keep this on the first page!
53queenbee is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 06:57 PM   #5
Glitter Guru
 
Join Date: Sep 2007
Location: Dallas
Posts: 5,509
Default

hey! I am in Texas too! In Carrollton just north of Dallas.
53queenbee is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 06:59 PM   #6
Insane Embellisher
 
Join Date: Nov 2005
Location: Texas
Posts: 3,197
Default

Quote:
Originally Posted by 53queenbee View Post
Mine did that once but I unplugged everything and let it rest for about a minute and replugged it again. I have the original, first day they came out model and I cannot put the cartridge in but one way to make it work.

I am no help huh? But, I can keep this on the first page!
Thank you!
__________________
Martha

My Gallery
Marthar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-09-2009, 07:00 PM   #7
Insane Embellisher
 
Join Date: Nov 2005
Location: Texas
Posts: 3,197
Default

Quote:
Originally Posted by 53queenbee View Post
hey! I am in Texas too! In Carrollton just north of Dallas.
DeSoto, south of Dallas!
__________________
Martha

My Gallery
Marthar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2009, 04:01 AM   #8
Pearl-ExPert
 
lylacfey's Avatar
 
Join Date: Feb 2007
Posts: 2,708
Default

I post a lot over at the Cricut board so my information is good. If you call ProvoCraft they will help you. Your machine should not be doing that. Call during the morning so you can get in. The wait time can be horrendous but they are trying to improve. ProvoCraft are Mountain Time zone. They have really great customer service so if you get somebody who won't help you out then call back. I don't think that will happen. You can also go over to the MB and one of the girls or guys over there can help. We have been through all the Cricut messes. It sounds like you have a loose connection. Don't give up hope.
__________________
DeeAnn

http://www.pinterest.com/faerydreams
lylacfey is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2009, 04:32 AM   #9
Pearl-ExPert
 
Join Date: Nov 2007
Posts: 3,013
Default

Martha....As the previous poster stated, call Provo. Assuming you have registered your machine and have proof of purchase. They'll send you out a new machine and you return the defective one in the box the replacement comes in. They pay return postage and you pay nothing for the replacement machine or postage. You do need to have patience to wait on the phone to get a Customer Service Rep. Be sure also to have the serial number handy for your machine. It's the bar code on the bottom of the unit.

If your machine is over 1 year old, then unfortunately, you are out of luck for a replacement.

Patti
pjw2855 is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Old 08-10-2009, 12:32 PM   #10
Insane Embellisher
 
Join Date: Nov 2005
Location: Texas
Posts: 3,197
Default

Thank you DeeAnn and Patti. I called this morning and she told me about the return scenario. I'm hoping my son can find his receipt or credit statement. You know college kids.
__________________
Martha

My Gallery
Marthar is offline  
Tweet this Post! Share on Facebook Reddit!! Pin on Pinterest! Share on Google+!
Reply With Quote
Reply





Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off